Skip to main content

I get a playback error when trying to stream videos

Some sites require a specific component from Google called Widevine to stream protected videos. This component is required by Netflix, Amazon Prime, Disney+, and many other streaming services.

To get it working go to Settings->Extensions (or navigate to brave://settings/extensions) and enable the option named Widevine near the bottom of the section.

Widevine option

 

Finally load or reload the page with the video that you are having trouble with, and Brave should prompt you to install the Widevine component.

 

If Widevine is already installed navigate to brave://components and press "Check for updates" under the Widevine Content Decryption Module entry.